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∆ΡΑΣΤΗΡΙΟΤΗΤΕΣ 

 

Ενότητα:    ∆ηµοτικό ∆ιαδικτυακό Ραδιόφωνο και Τηλεόραση 

Υποενότητα:  Y4 – ∆ηµιουργία διαδικτυακής ραδιοφωνικής εκποµπής µε τα εργαλεία 

Shoutcast και Winamp  

 

Το εκπαιδευτικό υλικό υπόκειται σε Άδεια Χρήσης 

Creative Commons  Αναφορά –Μη-Εµπορική Χρήση –Όχι Παράγωγο Έργο v. 3.0 

 

 

Λίστα ∆ραστηριοτήτων 

 

Κωδικός Τίτλος Επίπεδο 

Υ4.∆1  Εγκατάσταση εφαρµογών  και µεταφόρτωση υλικού L1– Εισαγωγική 

Υ4.∆2 Αναπαραγωγή αρχείων και λίστας αρχείων L1– Εισαγωγική 

Υ4.∆3  Αναζήτηση σταθµών L1– Εισαγωγική 

Υ4.∆4  Μετάδοση ήχου ζωντανά µε χρήση Winamp και SHOUTcast  
Server 

L2– Μέτρια 
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Ταξινόµηση ∆ραστηριοτήτων 

 

L1 - Εύκολες L2 - Μέτριες L3 - ∆ύσκολες 

Κωδικός Τίτλος Κωδικός Τίτλος Κωδικός Τίτλος 

Υ4.∆1  Εγκατάσταση 
εφαρµογής VLC και 
µεταφόρτωση 
υλικού 
δραστηριοτήτων 

Υ4.∆4  Μετάδοση ήχου 
ζωντανά µε χρήση 
Winamp και 
SHOUTcast Server 

  

Υ4.∆2  Αναπαραγωγή 
αρχείων και λίστας 
αρχείων 

  
  

Υ4.∆3  Αναζήτηση σταθµών     
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∆ραστηριότητα : Υ4.∆1 – Εγκατάσταση εφαρµογών και µεταφόρτωση υλικού 

δραστηριοτήτων 

Επίπεδο  : L1 – Εισαγωγική  (διάρκεια: 10 λεπτά) 

 

 

Σύντοµη Περιγραφή 

 

Η δραστηριότητα αυτή είναι προπαρασκευαστική για τις επόµενες δραστηριότητες. Και αυτό 

διότι στα πλαίσια αυτής της δραστηριότητας θα εγκαταστήσετε την εφαρµογή Winamp. 

 

Στόχοι ∆ραστηριότητας 

 

Όπως αναφέρθηκε, η παρούσα δραστηριότητα είναι προπαρασκευαστική για τις επόµενες 

δραστηριότητες.  

 

Απαιτούµενη Υποδοµή – Οδηγίες 

 

Για την υλοποίηση της δραστηριότητας απαιτούνται  

1) Χρήση Η/Υ µε πρόσβαση στο διαδίκτυο  

2) Λογισµικό πλοήγησης στον Παγκόσµιο Ιστό (web browser) 

3) Η δραστηριότητα αυτή αφορά περιβάλλοντα Windows 

 

 

Σενάριο 

 

Θα εγκαταστήσετε την εφαρµογή Winamp στον υπολογιστή σας.  
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Ανάλυση ∆ραστηριότητας  

 

Βήµα 1:  Εγκατάσταση του εργαλείου Winamp 

1.1 Ανοίξτε τον φυλλοµετρητή (web browser) στον υπολογιστή σας και εισάγετε τη 

διεύθυνση (http://www.winamp.com) 

1.2 Ακολουθείστε το σύνδεσµο “Free Download” στη µέση  της σελίδας για να 

µεταφορτώσετε το πρόγραµµα εγκατάστασης του Winamp.  

1.3 Αφού ολοκληρωθεί η µεταφόρτωση, εγκαταστήστε το εργαλείο Winamp. Μπορείτε να 

ανατρέξετε και στο Εκπαιδευτικό Υλικό Αναφοράς της Υποενότητες για τις οδηγίες 

εγκατάστασης.  

 

Βήµα 2:  Μεταφόρτωση υλικού για τις δραστηριότητες 

2.1 Εάν δεν είστε συνδεµένοι στην πλατφόρµα elearn.kedke.gr/moodle, συνδεθείτε και 

µεταβείτε στην Ενότητα « ∆ηµοτικό ∆ιαδικτυακό Ραδιόφωνο και Τηλεόραση». 

2.2 Στη συνέχεια µεταβείτε στην υποενότητα Υ4 και κάνετε κλικ στο σύνδεσµο κάτω από το  

«Υλικό για τις ∆ραστηριότητες της Υποενότητας» προκειµένου να µεταφορτώσετε το 

απαραίτητο υλικό για τις δραστηριότητες.  

2.3 Αποσυµπιέστε το υλικό και φροντίστε να το εγκαταστήσετε στο κατάλογο C://broadcast .  

2.4 Ελέγξτε ότι η δοµή του υποκαταλόγου είναι σύµφωνη µε αυτή της ακόλουθης εικόνας: 
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∆ραστηριότητα : Υ4.∆2 – Αναπαραγωγή αρχείων και λίστας αρχείων 

Επίπεδο  : L1 – Εισαγωγική  (διάρκεια: 15 λεπτά) 

 

 

Σύντοµη Περιγραφή 

 

Στα πλαίσια της παρούσας δραστηριότητας θα αναπαράγετε αρχεία ήχου προκειµένου να 

εξοικειωθείτε µε την εφαρµογή Winamp. 

 

Στόχοι ∆ραστηριότητας 

 

Η δραστηριότητα αυτή στοχεύει στο να γνωρίσετε τις βασικές λειτουργικότητες της εφαρµογής 

Winamp, όσο αφορά στην αναπαραγωγή αρχείων ήχου και λιστών αρχείων.  

 

Απαιτούµενη Υποδοµή – Οδηγίες 

 

Για την υλοποίηση της δραστηριότητας απαιτούνται  

1) Χρήση Η/Υ µε πρόσβαση στο διαδίκτυο  

2) Λογισµικό πλοήγησης στον Παγκόσµιο Ιστό (web browser) 

3) H εφαρµογή Winamp 

4) Ηχεία ή ακουστικά κεφαλής 

5) Η δραστηριότητα αυτή αφορά περιβάλλοντα Windows 

 

Σενάριο 

 

Θα χρησιµοποιήσετε την εφαρµογή Winamp για να αναπαράγετε αρχεία ήχου και λίστες αρχείων 

προς αναπαραγωγή. Θα «παίξετε» µε τις δυνατότητες της εφαρµογής Winamp. 
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Ανάλυση ∆ραστηριότητας 

 

Βήµα 1:  Aναπαραγωγή αρχείου ήχου   

1.1 Καλέστε την εφαρµογή Winamp. Ανοίξτε το αρχείο ήχου c:\broadcast\media\song1.mp3   

Bοήθεια: File -> Play File. 

1.2 Παρατηρείστε στο πάνω αριστερό µέρος του παραθύρου τον τίτλο, τη διάρκεια του 

τραγουδιού και την τρέχουσα χρονική στιγµή της αναπαραγωγής.  

1.3 Σταµατήστε την αναπαραγωγή µε το πλήκτρο «Τερµατισµός (Stop)».  

1.4 Ξεκινήστε την αναπαραγωγή µε το πλήκτρο «Έναρξη (Play)».   

1.5 Παγώστε την αναπαραγωγή και ξεκινήστε την µε το πλήκτρο «Παύση (Pause)»   

1.6 Επιλέξτε το “Local Media” (διπλό κλικ) στο αριστερό µενού και µετά “Audio” για να δείτε 

τη λίστα αναπαραγωγής.  

1.7 Αυξοµειώστε την ένταση του ήχου.  

1.8 Επιλέξτε τα εφέ του ήχου (View->Equalizer), ενεργοποιήστε το equalizer (επιλέξτε ΟΝ) 

και «παίξτε» µε αργό ρυθµό µε τις ρυθµίσεις.   

 

Βήµα 2:  Πληροφορίες για το αρχείο ήχου 

2.1 Επιλέξτε από το κύριο µενού File-> View Info.  

2.2 Παρατηρείστε στην κατηγορία “Format Info”, τις πληροφορίες σχετικά µε το τύπο της 

αναπαραγόµενης ροής, τον τύπο κωδικοποίησης, το αριθµό των καναλιών, το ρυθµό 

δειγµατοληψίας και κωδικοποίησης.  

 

Βήµα 3:  Aναπαραγωγή λίστας αρχείου ήχου  

3.1 Ανοίξτε (File->Open playlist) το αρχείο λίστας αρχείων προς αναπαραγωγή (playlist) 

c:\broadcast\media\winamp.pls   

3.2 Επιλέξτε το εικονίδιο playlist για να δείτε τη λίστα αναπαραγωγής.  

3.3 Επιλέξτε το πλήκτρο «Επόµενο κοµµάτι (next track)». 

3.4 Επιλέξτε το πλήκτρο «Προηγούµενο κοµµάτι (next track)». 

3.5 Κλείστε την εφαρµογή Winamp. 
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∆ραστηριότητα : Υ4.∆3 – Αναζήτηση Σταθµών 

Επίπεδο  : L1 – Εισαγωγική  (διάρκεια: 10 min) 

 

 

Σύντοµη Περιγραφή 

 

Στα πλαίσια της παρούσας δραστηριότητας θα αναζητήσετε ραδιοφωνικές και τηλεοπτικές 

εκποµπές στο ∆ιαδίκτυο µέσω της εφαρµογής Winamp. 

 

 

Στόχοι ∆ραστηριότητας 

 

Η δραστηριότητα αυτή στοχεύει στην εξοικείωσή σας µε τις υπηρεσίες ανεύρεσης ραδιοφωνικών 

και τηλεοπτικών εκποµπών που παρέχει η εφαρµογή Winamp. 

 

Απαιτούµενη Υποδοµή – Οδηγίες 

 

Για την υλοποίηση της δραστηριότητας απαιτούνται  

1) Χρήση Η/Υ µε πρόσβαση στο διαδίκτυο  

2) Λογισµικό πλοήγησης στον Παγκόσµιο Ιστό (web browser) 

3) Η εφαρµογή Winamp  

4) Ηχεία ή ακουστικά κεφαλής 

5) Η δραστηριότητα αυτή αφορά περιβάλλοντα Windows 

 

 

Σενάριο 

 

Θα αναζητήσετε και παρακολουθήσετε ραδιοφωνικές και τηλεοπτικές εκποµπές.  
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Ανάλυση ∆ραστηριότητας 

 

Βήµα 1:  Υπηρεσίες ανεύρεσης ραδιοφωνικών εκποµπών   

1.1 Ανοίξτε την εφαρµογή Winamp.   

1.2 Επιλέξτε από το αριστερό µενού το “Online Services”. Θα εµφανιστεί ένας κατάλογος µε 

τις “SHOUTcast Radio”, “SHOUTcast TV”, “AOL Radio” κ.α. 

1.3 Επιλέξτε  το “SHOUTcast Radio”. Θα εµφανιστεί ένας µακρύς κατάλογος ραδιοφωνικών 

σταθµών.  

1.4 Στο πεδίο αναζήτησης γράψτε “Greek” και µετά κλικ στο “Search”. 

1.5 Επιλέξτε κάποιο σταθµό από τον κατάλογο. Καλή σας ακρόαση ! 

 

Βήµα 2:  Υπηρεσίες ανεύρεσης τηλεοπτικών εκποµπών   

2.1 Επιλέξτε από το αριστερό µενού το “Online Services”. Θα εµφανιστεί ένας κατάλογος µε 

τις “SHOUTcast Radio”, “SHOUTcast TV”, “AOL Radio” κ.α. 

2.2 Επιλέξτε  το “SHOUTcast TV”. Θα εµφανιστεί ένας µακρύς κατάλογος ραδιοφωνικών 

σταθµών.  

2.3 Επαναλάβετε τα βήµατα 1.4 -1.5. 
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∆ραστηριότητα : Υ4.∆4 – Μετάδοση ροής ήχου µε χρήση Winamp και Shoutcast Server 

Επίπεδο  : L2 – Μέτρια (διάρκεια: 15 min) 

 

 

Σύντοµη Περιγραφή 

 

Στα πλαίσια της παρούσας δραστηριότητας θα δοκιµάσετε να µεταδώσετε ζωντανά το ήχο σας, 

από τον Η/Υ στο ∆ιαδίκτυο χρησιµοποιώντας την εφαρµογή Winamp και ενός  Shoutcast  

Server. H λύση αυτή µπορεί να χρησιµοποιηθεί για τη δηµιουργία ενός αµιγώς διαδικτυακού 

ραδιοφωνικού σταθµού. 

 

Στόχοι ∆ραστηριότητας 

 

Η δραστηριότητα αυτή στοχεύει στην εξοικείωσή σας µε τη χρήση του Winamp ως λογισµικό 

εκποµπής προς έναν Shoutcast Server. 

 

Απαιτούµενη Υποδοµή – Οδηγίες 

 

Για την υλοποίηση της δραστηριότητας απαιτούνται  

1) Χρήση Η/Υ µε πρόσβαση στο διαδίκτυο και κάρτα ήχου 

2) Λογισµικό πλοήγησης στον Παγκόσµιο Ιστό (web browser) 

3) O Shoutcast server εγκατεστηµένος στον H/Y σας. ∆είτε την αντίστοιχη υποενότητα 

«Shoutcast Server» 

4) Ο Winamp Player εγκατεστηµένος στον H/Y σας  

5) To SHOUTcast Radio DSP plug-in for Winamp  

6) Ηχεία ή ακουστικά κεφαλής συνδεµένα στην κάρτα ήχου σας 

7) Το υλικό για τις δραστηριότητες (∆είτε τη ∆ραστηριότητα 1, στο παρόν φύλλο 

δραστηριοτήτων) 

8) Η δραστηριότητα αυτή αφορά περιβάλλοντα Windows 
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Σενάριο 

 

Θα προσοµοιώσετε τη δηµιουργία ενός αµιγώς διαδικτυακού ραδιοφωνικού χρησιµοποιώντας 

την εφαρµογή Winamp και Shoutcast Server.  

 

  

Ανάλυση ∆ραστηριότητας 

 

 

Βήµα 1:  Εγκατάσταση του SHOUTcast Radio DSP plug-in for Winamp  

1.1 Μεταφορτώστε το αρχείο εγκατάστασης του «SHOUTcast Radio DSP plug-in for 

Winamp», το οποίο είναι διαθέσιµο στη ιστοσελίδα: 

http://www.shoutcast.com/download. 

1.2 Μόλις µεταφορτώσετε το SHOUTcast Radio DSP plug-in, κλείστε την εφαρµογή Winamp, 

εάν είναι ανοικτή και εκτελέστε το αρχείο εγκατάστασης. Ακολουθείστε κατά την 

εγκατάσταση τις προεπιλογές. Μπορείτε να ανατρέξετε και στο Εκπαιδευτικό Υλικό 

Αναφοράς της Υποενότητες για τις οδηγίες εγκατάστασης 

 

Βήµα 2:  Εγκατάσταση του SHOUTcast DNAS  

2.1 Μεταφορτώστε το αρχείο εγκατάστασης του «SHOUTcast DNAS», το οποίο είναι 

διαθέσιµο στη ιστοσελίδα: http://www.shoutcast.com/download . 

2.2 Μόλις µεταφορτώσετε αρχείο εγκατάστασης και εκτελέστε. Ακολουθείστε κατά την 

εγκατάσταση τις προεπιλογές. 

 

Βήµα 3:  Τερµατισµός του DSS ή Icecast server 

3.1 Σε περίπτωση που είναι σε λειτουργία ο DSS θα πρέπει να τον τερµατίσετε καθώς 

χρησιµοποιεί κοινές δικτυακές θύρες µε τον Icecast/Shoutcast server. Boήθεια. Start-

>Control Panel -> Administration tools -> Services. Επιλέξτε το Darwin Streaming 

Server και στη συνέχεια stop. Καλέστε το Windows Task Manager (ALT-CTRL-DEL) και 

βεβαιωθείτε ότι στις διεργασίες (Processes) ∆ΕΝ εµφανίζεται η διεργασία του DSS. 

3.2 Παροµοίως τερµατίστε τον Icecast server. 

 

Βήµα 4:  Έναρξη και έλεγχο του Shoutcast server. 

4.1 Ξεκινήστε το Shoutcast server. Boήθεια. Start->All Programs -> ShoutCAST DNAS 

(GUI). Σε περίπτωση που δεν είναι εγκατεστηµένος µεταβείτε στην υποενότητα 

“Shoutcast Streaming Server” προκειµένου να ακολουθήσετε τις οδηγίες εγκατάστασης.  
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4.2 Βεβαιωθείτε ότι έχετε προσθέσει το Shoutcast server (sc_serv) στα Exceptions του 

Windows Firewall, όπως φαίνεται στην ακόλουθη εικόνα.  

 

 

Εικόνα 1: Firewall 

4.3 Ανοίξτε µε έναν πλοηγητή το σύνδεσµο http://127.0.0.1:8000 για να βεβαιωθείτε ότι ο 

Shoutcast server είναι σε λειτουργία. 

 

Βήµα 5:  Κλήση του Winamp    

5.1  Ξεκινήστε την εφαρµογή Winamp, ανοίξτε τα Preferences ( Options -> Preferences ή 

CTRL-P) και κάντε κλικ πάνω στην υποκατηγορία DSP/effects subcategory που βρίσκεται 

στην κατηγορία “Plug-ins”. Στη συνέχεια επιλέξτε το plugin Nullsoft SHOUTcast DSP 

(Εικόνα 2). 
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Εικόνα 2: Επιλογή plug-in 

 

5.2 Το επόµενο βήµα είναι να θέσετε τις παραµέτρους µετάδοσης και κωδικοποίησης. 

Επιλέξτε το “Configure active plug-in”. Στη συνέχεια επιλέξτε την κατηγορία Output και 

την επιλογή Connection (δείτε την Εικόνα 3). ∆ώστε τα στοιχεία του εξυπηρετητή 

SHOUTcast που θα χρησιµοποιήσετε, τη θύρα (τυπική τιµή 8000), το κωδικό που σας 

έχει δοθεί. ∆ώστε localhost, 8000 και changeme. 

 

5.3 Επιπλέον, µπορείτε να επιλέξετε την επιλογή Yellow Pages (Εικόνα 4) προκειµένου να 

δώσετε στοιχεία για το σταθµός σας, όπως περιγραφή, τίτλος, σύνδεσµος σταθµού.  
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Εικόνα 3: Στοιχεία εξυπηρετητή 

 

 

Εικόνα 4: Στοιχεία µετάδοσης 
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Εικόνα 5: Eπιλογή τύπου κωδικοποίησης 

 

5.4  Από την κατηγορία Encoder (Εικόνα 5) επιλέξετε το τύπο κωδικοποίησης του ήχου από 

τις επιλογές MP3, AAC+, AAC LC. Επιλέξτε AAC. 

 

 

Εικόνα 6: Επιλογή στοιχείων κωδικοποίησης 

 

5.5 Από την επιλογή “Encoder Settings” (Εικόνα 6) επιλέξτε τα στοιχεία της κωδικοποίησης 

όπως ρυθµός κωδικοποίησης, αριθµός καναλιών, τύπος ροής. 

 

5.6 Από την κατηγορία Input (Εικόνα 7) µπορείτε να επιλέξτε εάν η είσοδος θα είναι ότι 

αναπαράγει η εφαρµογή Winamp ή η κάρτα ήχου σας. Σε περίπτωση που επιλέξετε το 

πρώτο, ο σταθµός σας θα εκπέµπει ότι «παίζει» η εφαρµογή Winamp. Με αυτό τον τρόπο 

µπορείτε να δηµιουργήσετε έναν αµιγώς διαδικτυακό ραδιοφωνικό σταθµό. Σε 

περίπτωση που επιλέξετε το δεύτερο, µπορείτε να οδηγήσετε στη κάρτα ήχου σας 



σελ. 15 από 15 

 

οποιαδήποτε πηγή θέλετε, για παράδειγµα µία έξοδο από το ραδιοφωνικό FM σταθµό 

σας. Με αυτό τον τρόπο µπορείτε να αναµεταδίδετε στο διαδίκτυο το ραδιοφωνικό 

σταθµό σας. 

 

 

Εικόνα 7: Επιλογή εισόδου για την εκποµπή 

 

5.7 Μεταβείτε στην κατηγορία Output και επιλέξτε Connect. 

 

5.8 Συνδεθείτε από άλλον υπολογιστή µε την εφαρµογή Winamp στο 

http://ip_address:8000/listen.pls  όπου ip_address η IP διεύθυνση του υπολογιστή σας. 

 

5.9 Μπορείτε να συνδεθείτε από τον υπολογιστή σας στο http://localhost:8000/listen.pls 

χρησιµοποιώντας άλλη εφαρµογή από αυτή της Winamp, όπως το VLC 

(http://www.videolan.org) ή το KMPlayer (http://kmplayer.en.softonic.com/). 


